Highly Liquid Forum facebook twitter google plus rss feed
  #1  
Old 08-30-2013, 07:48 PM
Jim U Jim U is offline
Junior Member
 
Join Date: Jul 2013
Posts: 14
Default Problem configuring MD24

After about a day trying to configure my MD24s to operate indicator lights in response to specific key on/off messages, they seem to work; but here's what I ran into:

I had used MIDI-OX with MIDIMAN 2X2 to send long SYSEX files to MIDI-CPUs with no problem. Using the same procedure, the MD24 Rev G v 1.3 seems to only capture the first ct definition line. MIDI-OX reports that it sent the whole file The ACT light blinks thrice as expected; however, all but the ct defined in the first line are unchanged. I worked around this by sending the SYSEX file 24 times, deleting the first line after each send. What's going wrong?

I don't know how to dump the configuration contents via the MIDI OUT port as described in the manual. Do I send some specific SYSEX message or what. I have done this with MIDI-CPU before but how does MD24 work. (Note that diagnosing my problem above would have been simple had I been able to do this.)

The manual talks about restoring the default using JP1, which doesn't exist on Rev G. Is there a program switch setting or something for this purpose?

Here's the SYSEX file I was using: The note values correspond to the organ stop matrix and the best wiring paths and are not just jumbled. This works BTW.

F0 00 01 5D 03 01
00 01 06 28
01 01 06 2C
02 01 06 5A
03 01 06 2B
04 01 06 59
05 01 06 2A
06 01 06 58
07 01 06 29
08 01 06 63
09 01 06 57
0A 01 06 62
0B 01 06 56
0C 01 06 61
0D 01 06 55
0E 01 06 60
0F 01 06 54
10 01 06 6B
11 01 06 5F
12 01 06 6A
13 01 06 5E
14 01 06 69
15 01 06 5D
16 01 06 68
17 01 06 5C
F7

Could use a little help,
Jim U

Last edited by Jim U; 09-22-2013 at 08:23 PM.
Reply With Quote
  #2  
Old 09-05-2013, 02:15 PM
John's Avatar
John John is offline
Moderator
 
Join Date: Jan 2009
Posts: 3,007
Default

Hi Jim, sorry to hear that you're having trouble getting the MD24 configured.

Quote:
Originally Posted by Jim U View Post
After about a day trying to configure my MD24s to operate indicator lights in response to specific key on/off messages, they seem to work; but here's what I ran into:

I had used MIDI-OX with MIDIMAN 2X2 to send long SYSEX files to MIDI-CPUs with no problem. Using the same procedure, the MD24 Rev G v 1.3 seems to only capture the first ct definition line. MIDI-OX reports that it sent the whole file The ACT light blinks thrice as expected; however, all but the ct defined in the first line are unchanged. I worked around this by sending the SYSEX file 24 times, deleting the first line after each send. What's going wrong?
Hmm. I'm not sure why this would happen, but unfortunately, there is still a chance that the MIDI driver is truncating the MIDI message for some reason. (Despite your earlier success with te MIDI CPU. I am at a loss to explain the unpredictable nature of sysex transmission from a computer. More here.)

Quote:
I don't know how to dump the configuration contents via the MIDI OUT port as described in the manual. Do I send some specific SYSEX message or what. I have done this with MIDI-CPU before but how does MD24 work. (Note that diagnosing my problem above would have been simple had I been able to do this.)
The MD24 firmware 1.3 does not include this feature, sorry!

Quote:
The manual talks about restoring the default using JP1, which doesn't exist on Rev G. Is there a program switch setting or something for this purpose?
The init jumper function is note supported on Rev G. Sorry for the confusion. That should be deleted from the firmware manual.

I'm glad that you were able to work around the issues. (Do you anticipate having to reconfigure the MD24 frequently?) I'm sorry to hear about the hassle. An MD24 firmware rewrite / redesign is likely in order to address these problems.
Reply With Quote
  #3  
Old 09-06-2013, 01:39 AM
Jim U Jim U is offline
Junior Member
 
Join Date: Jul 2013
Posts: 14
Default

Thanks for the handshake. I only expect to do this a few more times so it's not worth experimenting with a different interface. It's not that much more trouble: (select; delete; send sysex) x 23.

I was mostly looking for a sanity check which you provided. Maybe help some of the other user that might have encountered something like this.

Jim U
Reply With Quote
Reply

Tags
md24, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.